$re = '/^.*?\S$/m';
$str = 'Jake
John
Mary Anne
Don
David ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);