$re = '/^(?:\[club1234\|[^\]]+\])(?:[\s.,\'\"!?\-+]+|$)/m';
$str = '[club1234|123], помощь';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);