const regex = /^(?=.*oursites)(?!.*externalusers).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*oursites)(?!.*externalusers).*', 'gm')
const str = `http://contoso.com/oursites/Home.aspx
http://contoso.com/oursites/discussions.aspx
http://contoso.com/oursites/policies.aspx
http://contoso.com/oursites/externalusers.aspx
http://contoso.com/oursites/calendar.aspx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}