$re = '/Votre vol(:?([0-9]{1,2}\s[^\s]+?\s[0-9]{4})|.+?)+/';
$str = 'Votre vol : Casablanca - Paris Mercredi 31 août 2016 AF1197 - Ecoi 7 septembre 2016 AF1196 - Economy 15:20 Paris , Charles de Gaulle (CDG) , FRANCE - Terminal 2E Heure Limite d\'Enregister un supplément.
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);