re = /^[1-9]\d{5}[1-9]\d{3}((0\d)|(1[0-2]))(([0|1|2]\d)|3[0-1])\d{3}([0-9]|X)$/
str = '500104199304070818'
# Print the match result
str.match(re) do |match|
puts match.to_s
end