re = /"(.+?)"/m
str = '"https://text/text/........./text<b>.jpg?text=text&text=.......</b>"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end