re = /City:\s*(?P<City>[^,]+?)\s*,\s*Zip:\s*(?P<Zip>\d+)/m
str = 'Zip Code Details: City: Huntsville_Alabama , Zip: 35808 , 801thru816 City: Anchorage_Alaska , Zip: 99506
Zip Code Details: City: Miami_Florida , Zip: 33128 , 124thru190 City: Atlanta_Georgia , Zip: 30301 , 301thru381'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end