re = /(?<!@)\b((http(s)?:\/\/)?((\d+)\.)?[a-zA-Z0-9.-]+\.[a-zA-Z]{2,})(\/[^\s]*)?\b/m
str = 'https://regex101.com/
http://regex101.com/
http:127.0.0.1
regex101.com
example.com.au
info@email.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end