re = /:(?=~)/
str = '_Fruit|Apple:~Vegetable|Carrot:~fruitfunc|Package::User::Today:~datefunct|{~date}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end