$re = '/(\d+\))([^\d]*)/m';
$str = '1) some text 2) some more text 3) even more text, with commas and such 4) bye!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);