package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)`)
var str = `「近幾個月來,XXX Holdings的股票一直處於壓力之下,可能更多的是與市場上其他成長型公司一起被不分青紅皂白地拋售(其中許多是獲利前的公司,而其拋售的說法則是基於長期的營收預估),儘管我們認為該公司的基本面非常穩固。 12月,加州公共事業委員會提出的新法規將使住宅式屋頂太陽能電池板發電的成本提高,此進一步加劇Generac的下跌。 Generac的產品通常與住宅太陽能電力系統結合使用,並經常會與替代能源並行。 我們不知道這種輪換會持續多久,但也不認為價格壓力是由基本面決定,所以我們傾向於維持Generac的持股。鑒於Generac的財務狀況穩定、良好的執行力和持續的獲利成長(自2010年以來的年複合成長率為+12到13%),該股價理應擁有溢價空間。從目前的市場輪動以及對該公司長期發展來看,2023年13.75億美元的EBITDA估計值理應達18.5倍,從目前的股價水準來看尚有40%的潛在上漲空間。
投資論點的關鍵因素總結如下。
- 有吸引力的長期增長前景。家庭備用發電機的巨大滲透機會(目前覆蓋率只有約5%)。除了家庭備用發電機,Generac的其他事業的發展似乎尚未獲得市場的重視(即存儲/管理,5G,電網服務等)。
- 競爭優勢。Generac已經建立了一個高度信任和可信的品牌信譽,廣泛的銷售通路,產品的領先地位,以及創造市場的成功記錄。
- 處於獨特的地位,可以從日益嚴重的氣候變遷中獲益,不僅透過能源轉型增加需求,且擁有政府資金挹注。
- 訂單積壓。盡管GNRC繼續提高增量以減少訂單積壓的壓力,但其發電機的交貨時間仍然超過30週(一些經銷商聲稱更高)。博鰲亞洲論壇認為,訂單積壓的銷售量超過10億美元,此數字為2013年桑迪颶風後訂單積壓規模的8倍。與2013年不同的是,GNRC在非旺季時見到訂單積壓的高峰,該公司在風暴季節開始之前就有大量的訂單積壓。這對價格和長期生產都是正向的訊息。
- 強大的資產負債表和現金流的產生使得公司在資本分配決策方面採取了嚴謹和平衡的方法。管理層看好四個關鍵領域機會:發電、儲能、能源監測和能源管理。公司的凈槓桿率為0.6倍,相對於2-4倍的目標,公司有很穩健的財務能力。
其他需要考慮的財務亮點。
- 本年度銷售額為34億美元,EBITDA為7.98億美元,約為23.25%。
- 本年度的財務狀況為4.52億美元(約86%的轉換率)。
- 本季度ROE35.1%,CFROI24.2%。
- 凈杠桿0.6倍EBITDA,利息覆蓋率15.4倍」
投資建議:「持股續抱」
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}