package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w[\w \t]{2,9}\z`)
var str = `Frog`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}