import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\{\\{]++|\\{(?!\\{)) \n"
+ "| \n"
+ "\\{\\{(\\w+)\n"
+ " (?: \\s+ (\\w+(?:=(?:\"((?:\\\\\\\\\\\\\\\\|\\\\\"|[^\"]++)*)\"|'((?:\\\\\\\\\\\\\\\\|\\\\'|[^']++|)*)'))? ) )*\n"
+ "\\}\\}\n"
+ " ((?R)*)\n"
+ "\\{\\{/\\g\\{-5\\}\\}\\} \n"
+ "| \n"
+ "\\{\\{(\\w+)(?: \\s+ (\\w+(?:=(?:\"((?:\\\\\\\\\\\\\\\\|\\\\\"|[^\"]++)*)\"|'((?:\\\\\\\\\\\\\\\\|\\\\'|[^']++|)*)'))? )\n"
+ ")*\\}\\}";
final String string = "{{placeholder name=\"Alexey\"}}\n"
+ " sdasdasda\n"
+ "dasdad\n"
+ "ads\n"
+ "asdasd\n"
+ "sdasd\n"
+ "{{/placeholder}}\n"
+ "<div class=\"asdasdasd\">\n"
+ " {{cssArea}}\n\n"
+ " {{/cssArea}}\n\n"
+ " {{escaped open=\"\\\"sdfsdf\" close='dfdfg'}}\n"
+ " \n"
+ " {{/escaped}}\n"
+ "</div>\n"
+ "{{holder name='sadasdas'}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}