$re = '/(RED|GREEN|BLUE)(, (RED|GREEN|BLUE))*/m';
$str = 'RED, GREEN, BLUE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);