$re = '/\/(?:\d{2,3}(\d\d)|\d{3}(\d{3}))$/m';
$str = '/12345
/123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);