$re = '/^(?!.*\.spec\.js$).*\.js$/m';
$str = 'Some_file.spec.js
Some_file.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);