$re = '/^[a-zA-Z0-9]{0,5}$/';
$str = 'AV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);