const regex = /Json(?<json_output>[\s\S\d\D\w\W]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Json(?<json_output>[\\s\\S\\d\\D\\w\\W]*)', 'gm')
const str = `\`\`\`json
[
{
"Place": {
"Name": "Les Catacombes de Paris",
"Google_place_id": "ChIJVXealLU_xkcRja_At0z9AGY",
"City": "Paris",
"Region": "Île-de-France",
"Country": "France",
"Cultural_type": "Historical",
"Facts": {
"Historical_facts": {
"FACT_TYPE": "Did you know ?",
"FACTS": [
"Les Catacombes de Paris ont été créées à la fin du 18ème siècle pour résoudre le problème de surpeuplement des cimetières de la ville."
],
"INTERACTION": [
"Savez-vous pourquoi les catacombes ont été construites ?"
],
"CATEGORY": "Historical_facts"
},
"Architectural_facts": {
"FACT_TYPE": "Fun fact",
"FACTS": [
"Les catacombes sont faites d’anciens tunnels de carrières transformés pour stocker les ossements de plus de six millions de Parisiens."
],
"INTERACTION": [
"Combien de personnes pensez-vous que les catacombes peuvent contenir ?"
],
"CATEGORY": "Architectural_facts"
},
"Scientific_facts": {
"FACT_TYPE": "Wow",
"FACTS": [
"Les conditions dans les catacombes, qui sont fraîches et humides, permettent une bonne conservation des ossements."
],
"INTERACTION": [
"Que pensez-vous que l'humidité fait aux ossements ?"
],
"CATEGORY": "Scientific_facts"
},
"Mystery_legends_facts": {
"FACT_TYPE": "Did you know ?",
"FACTS": [
"Une légende urbaine raconte qu’il y a un cinéma secret dans les catacombes !",
"Il paraîtrait que des groupes se réunissent ici pour regarder des films."
],
"INTERACTION": [
"Aimeriez-vous visiter un cinéma caché ?",
"Quel genre de film pensez-vous qu’ils projettent là-bas ?"
],
"CATEGORY": "Mystery_legends_facts"
}
}
}
}
]
\`\`\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}