package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)`)
var str = `aaddbb1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}