re = /\[([^\]\[]*)\]\(([^\]\[]*)\)/m
str = 'Hey this is my [my bbc](http://www.bbc.co.uk), it is like [my other bbc](http://www.bbc.co.uk) site.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end