package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(Ahr)(o?)([^n])`)
var str = `Ahron`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}