#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:https?|ftp):\/\/)?(?:\S+(?::\S*)?@)?(?:((25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])\.){3}(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]|[0-9])|(?:(?:[a-z\u00a1-\uffff0-9]+-)*[a-z\u00a1-\uffff0-9]+)(?:\.(?:[a-z\u00a1-\uffff0-9]+-)*[a-z\u00a1-\uffff0-9]+)*(?:\.(?:[a-z\u00a1-\uffff]{2,})))(?::\d{2,5})?(?:\/[^\s]*)?"
Local $sString = "https://face.com" & @CRLF & _
"http://face.com" & @CRLF & _
"https://www.face.com/" & @CRLF & _
"face.com" & @CRLF & _
"www.face.com" & @CRLF & _
"w3.face.com" & @CRLF & _
"0.0.0.0" & @CRLF & _
"ac31.23.53.122asd" & @CRLF & _
"92.168.202.9712121212121" & @CRLF & _
"" & @CRLF & _
"1292.168.202.97" & @CRLF & _
"192.168.202.97" & @CRLF & _
"224.168.202.97" & @CRLF & _
"92.18.2.97" & @CRLF & _
"http://74.251.154.247/find-ip-address-of-web-site.html" & @CRLF & _
"" & @CRLF & _
"74.201.154.247/find-ip-address-of-web-site.html" & @CRLF & _
"" & @CRLF & _
"74.201.154.247" & @CRLF & _
"" & @CRLF & _
"foo.com" & @CRLF & _
"" & @CRLF & _
"http://92.18.2.97" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"asasasasasac31.23.53.122asasassasd" & @CRLF & _
"" & @CRLF & _
"12312312312321.32.34.2312312312321" & @CRLF & _
"" & @CRLF & _
"12.3423423432.234123123.123" & @CRLF & _
"" & @CRLF & _
"31.134232131.231.34" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"SHOULD MATCH:" & @CRLF & _
"" & @CRLF & _
"http://foo.com/blah_blah" & @CRLF & _
"http://foo.com/blah_blah/" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)_(again)" & @CRLF & _
"http://www.example.com/wpstyle/?p=364" & @CRLF & _
"https://www.example.com/foo/?bar=baz&inga=42&quux" & @CRLF & _
"http://✪df.ws/123" & @CRLF & _
"http://userid:password@example.com:8080" & @CRLF & _
"http://userid:password@example.com:8080/" & @CRLF & _
"http://userid@example.com" & @CRLF & _
"http://userid@example.com/" & @CRLF & _
"http://userid@example.com:8080" & @CRLF & _
"http://userid@example.com:8080/" & @CRLF & _
"http://userid:password@example.com" & @CRLF & _
"http://userid:password@example.com/" & @CRLF & _
"http://142.42.1.1/" & @CRLF & _
"http://142.42.1.1:8080/" & @CRLF & _
"http://➡.ws/䨹" & @CRLF & _
"http://⌘.ws" & @CRLF & _
"http://⌘.ws/" & @CRLF & _
"http://foo.com/blah_(wikipedia)#cite-1" & @CRLF & _
"http://foo.com/blah_(wikipedia)_blah#cite-1" & @CRLF & _
"http://foo.com/unicode_(✪)_in_parens" & @CRLF & _
"http://foo.com/(something)?after=parens" & @CRLF & _
"http://☺.damowmow.com/" & @CRLF & _
"http://code.google.com/events/#&product=browser" & @CRLF & _
"http://j.mp" & @CRLF & _
"ftp://foo.bar/baz" & @CRLF & _
"http://foo.bar/?q=Test%20URL-encoded%20stuff" & @CRLF & _
"http://مثال.إختبار" & @CRLF & _
"http://例子.测试" & @CRLF & _
"http://उदाहरण.परीक्षा" & @CRLF & _
"http://-.~_!$&'()*+,;=:%40:80%2f::::::@example.com" & @CRLF & _
"http://1337.net" & @CRLF & _
"http://a.b-c.de" & @CRLF & _
"http://223.255.255.254" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")