re = /^https?:\/\/[^\s\/$.?#].[^\s]*?(?:\.jpg)/i
str = 'https://upload.wikimedia.org/wikipedia/commons/2/25/Lebron_wizards_2017_%28cropped%29.jpg/498px-Lebron_wizards_2017_%28cropped%29.jpg
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end