$re = '/^(\d+(?:\.\d{1,2})?\/?\d+(?:\.\d{1,2})?)$/';
$str = '1.5/384.63';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);