// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http|https):\/\/([a-zA-Z-]+).([a-z]{2,}):?([0-9]{4})?((\/[a-zA-Z0-9?=]+){0,})(#[a-zA-Z0-9_-]{0,})?").unwrap();
let string = "https://yandex.ru:7890/video/455#hash_tag";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}