re = /^(?=.*\d)(?=.*[@#\-_$%^&+=§!\?])(?=.*[a-z])(?=.*[A-Z])[0-9A-Za-z@#\-_$%^&+=§!\?]{8,20}$/
str = 'Qwerty123!@#'
# Print the match result
str.match(re) do |match|
puts match.to_s
end