# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-z$]{3,5},(-\d+)?(\d+)(,[a-i](,-?\d+)?)?(,\d+(,[a-i](,-?\d+)?))?"
test_str = ("mch,32,i,-0,32,g,-8\n"
"REP,32,G,-0,32,I,3\n"
"SRH,268,I,-0\n\n\n"
"SRH,268,I,50\n\n"
"mch,32,i,5,32,g,8 mch,32,i,-0,32,g,8\n"
"mch,32,i,50,32,g,-8 mch,-0,32,g,8\n"
"mch,32,g,8,-0\n\n\n\n"
"srh,64,,5 <-- should not work\n"
"srh,64,z,5 <-- should not work\n"
"srh,64,i,5 <-- should work\n"
"SRH,898,,900\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.