package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ab{1,3}bbc`)
var str = `abbbc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}