# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{2,}|(x\d)|(\dx)|[^\W\d]+\d\w*|\d+[^\W\d]\w*"
test_str = ("Red 1996 Corvette 2x - Matchbox\n"
"3 x SmartCar, broken 2nd door\n"
"White chevy F150, 1996\n"
"2nd edition Kindle (x3)\n"
"**1x** 2008 financial crash notice\n"
"Green bowl, cracked (stored in room 2A5)\n"
"Collectors Edition Beannie Baby, item 204/343\n"
"(6) Nissan window motors (1995-1998 ONLY)")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.