re = /([^\/?]+)\/?$/im
str = 'https://www.example.com/int/de
https://www.example.com/int/de/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end