$re = '/^\w+(?:-\w+)*(?=\/?$)/m';
$str = 'These are valid:
aBc
ab-9/
a_C-c/
3-b-c
These are invalid:
aBc/xyz
1bc/x7z/
hello//
a-b_/89u/13P
a-b_/89u/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);