#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a\s+.*?href="https:\/\/code.amazon.com\/packages\/AWSBrewPricingPlcConsole\/releases\/(\d+)\.(\d+)\.(\d+)\.(\d+)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"" & @CRLF & _
" "http://www.w3.org/TR/html4/strict.dtd">" & @CRLF & _
"<html>" & @CRLF & _
"" & @CRLF & _
"<head>" & @CRLF & _
" <title>" & @CRLF & _
" AWSBrewPricingPlcConsole - Releases - Brazil Directory" & @CRLF & _
" </title>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"<!-- EXPERIMENTAL: Subject to change, don't rely on these -->" & @CRLF & _
"<meta name="environment" content="DevCentralWebsite">" & @CRLF & _
"<meta name="stage" content="Prod">" & @CRLF & _
"<!-- /EXPERIMENTAL -->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <link rel="stylesheet"" & @CRLF & _
" type="text/css"" & @CRLF & _
" href="https://internal-cdn.amazon.com/dtux.amazon.com/stylesheets/dtux-style.css">" & @CRLF & _
"" & @CRLF & _
" <link href="https://internal-cdn.amazon.com/devcentral.amazon.com/style/helptips.css"" & @CRLF & _
" rel="stylesheet"" & @CRLF & _
" type="text/css">" & @CRLF & _
"" & @CRLF & _
" <link rel="icon"" & @CRLF & _
" href="https://internal-cdn.amazon.com/devcentral.amazon.com/images/brazil.ico"" & @CRLF & _
" type="image/x-icon">" & @CRLF & _
" <link rel="shortcut icon"" & @CRLF & _
" href="https://internal-cdn.amazon.com/devcentral.amazon.com/images/brazil.ico"" & @CRLF & _
" type="image/x-icon">" & @CRLF & _
"" & @CRLF & _
" <link rel="stylesheet"" & @CRLF & _
" type="text/css"" & @CRLF & _
" href="https://internal-cdn.amazon.com/btk.amazon.com/ajax/libs/jquery/plugins/autocomplete/1.1/jquery.autocomplete.min.css">" & @CRLF & _
"" & @CRLF & _
" <link href="https://internal-cdn.amazon.com/devcentral.amazon.com/brazil/directory/stylesheet.min.css?size=24097"" & @CRLF & _
" rel="stylesheet"" & @CRLF & _
" type="text/css">" & @CRLF & _
"" & @CRLF & _
" <link rel="stylesheet" type="text/css" href="https://internal-cdn.amazon.com/devcentral.amazon.com/brazil/directory/visualizer/stylesheets/visualizer.min.css?size=1088" >" & @CRLF & _
"" & @CRLF & _
" <link rel="stylesheet"" & @CRLF & _
" type="text/css"" & @CRLF & _
" href="https://internal-cdn.amazon.com/is-it-down.amazon.com/stylesheets/stripe.css">" & @CRLF & _
"" & @CRLF & _
" <script type="text/javascript"" & @CRLF & _
" src="https://internal-cdn.amazon.com/btk.amazon.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>" & @CRLF & _
" <script type="text/javascript"" & @CRLF & _
" src="https://internal-cdn.amazon.com/dtux.amazon.com/javascripts/cache/dtux-style.js"></script>" & @CRLF & _
" <script type="text/javascript"" & @CRLF & _
" src="https://internal-cdn.amazon.com/btk.amazon.com/ajax/libs/jquery/plugins/autocomplete/1.1/jquery.autocomplete.min.js"></script>" & @CRLF & _
" <script type="text/javascript"" & @CRLF & _
" src="https://internal-cdn.amazon.com/btk.amazon.com/ajax/libs/jquery/plugins/tablesorter/2.0.3/jquery.tablesorter.min.js"></script>" & @CRLF & _
"" & @CRLF & _
" <script type="text/javascript"" & @CRLF & _
" src="https://internal-cdn.amazon.com/devcentral.amazon.com/brazil/directory/script.min.js?size=2302">" & @CRLF & _
" </script>" & @CRLF & _
"" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" IS_PROD = true;" & @CRLF & _
" REMOTE_USER = 'vladyang';" & @CRLF & _
" </script>" & @CRLF & _
"" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
"<div id="content">" & @CRLF & _
" <div class="inner-container">" & @CRLF & _
"" & @CRLF & _
" <div class="indexHeader">" & @CRLF & _
" <span class='titleBarTitle'>" & @CRLF & _
" " & @CRLF & _
"<a href="/">devcentral</a> >" & @CRLF & _
"" & @CRLF & _
" <a href="https://devcentral.amazon.com/ac/brazil/directory/">brazil directory</a>" & @CRLF & _
" > " & @CRLF & _
" <a href="https://devcentral.amazon.com/ac/brazil/directory/packages/by-owner">packages</a> > <a href="https://devcentral.amazon.com/ac/brazil/directory/package/overview/AWSBrewPricingPlcConsole">AWSBrewPricingPlcConsole</a> > <a href="https://devcentral.amazon.com/ac/brazil/directory/package/majorVersionSummary/AWSBrewPricingPlcConsole?majorVersion=1.3">1.3</a> > release notes" & @CRLF & _
"" & @CRLF & _
" </span>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div class='titleBarHelper'>" & @CRLF & _
" " & @CRLF & _
" <div id="searchBoxes">" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <form action="https://devcentral.amazon.com/ac/brazil/directory/packages/search"" & @CRLF & _
" id="findPackageForm">" & @CRLF & _
" <div>" & @CRLF & _
" Search Packages:" & @CRLF & _
" <input type="text" id="findPackage" name="q">" & @CRLF & _
" </div>" & @CRLF & _
" </form>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <form action="https://devcentral.amazon.com/ac/brazil/directory/version-sets/search"" & @CRLF & _
" id="findVersionSetForm">" & @CRLF & _
" <div>" & @CRLF & _
" Search Version Sets:" & @CRLF & _
" <input type="text"" & @CRLF & _
" id="findVersionSet"" & @CRLF & _
" class="versionSetInput"" & @CRLF & _
" name="q"" & @CRLF & _
" value="live">" & @CRLF & _
" </div>" & @CRLF & _
" </form>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <h1>Package: AWSBrewPricingPlcConsole</h1>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"<!--" & @CRLF & _
"Timing for addPackageToRoute (in seconds):" & @CRLF & _
"{" & @CRLF & _
" 'getBranchByPackageAndName' => '0.0113730430603027'," & @CRLF & _
" 'getPackageSynopsisByName' => '0.0839250087738037'" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"-->" & @CRLF & _
"" & @CRLF & _
"<div id="viewInLinks">" & @CRLF & _
"View in" & @CRLF & _
" <a href="/brazil/go/src-control?pkg=AWSBrewPricingPlcConsole">Code Browser</a>" & @CRLF & _
" |" & @CRLF & _
" <a href="https://omni-grok.amazon.com/s?path=/AWSBrewPricingPlcConsole&indexName=GitFarm_6">OmniGrok</a>" & @CRLF & _
"" & @CRLF & _
" |" & @CRLF & _
" <a href="https://apollo.amazon.com/package.html?packageName=AWSBrewPricingPlcConsole&showEnvironmentUsage=1">" & @CRLF & _
" Apollo" & @CRLF & _
" </a>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div id="headerWarning">" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div id="flash">" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"<div class="tabs has-subnav">" & @CRLF & _
"<ul>" & @CRLF & _
" <li class="tab "><a class=" "" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/overview/AWSBrewPricingPlcConsole">Overview</a></li>" & @CRLF & _
" <li class="tab "><a class=" "" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/branches/AWSBrewPricingPlcConsole">Branches</a></li>" & @CRLF & _
" <li class="tab "><a class=" "" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/releases/AWSBrewPricingPlcConsole">All Releases</a></li>" & @CRLF & _
" <li class="tab "><a class=" "" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/sourceGuidance/AWSBrewPricingPlcConsole">Source Guidance</a></li>" & @CRLF & _
" <li class="tab active"><a class="active vendor-guidance-NONE"" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/majorVersionSummary/AWSBrewPricingPlcConsole?majorVersion=1.3">1.3 </a></li>" & @CRLF & _
" <li class="tab "><a class=" vendor-guidance-NONE"" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/majorVersionSummary/AWSBrewPricingPlcConsole?majorVersion=1.0">1.0 </a></li>" & @CRLF & _
"</ul>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"<div class="subtabs">" & @CRLF & _
"<ul>" & @CRLF & _
" <li class="subtab "><a class=" "" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/majorVersionSummary/AWSBrewPricingPlcConsole?majorVersion=1.3">Summary</a></li>" & @CRLF & _
" <li class="subtab active"><a class="active "" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/notes/AWSBrewPricingPlcConsole?majorVersion=1.3">Releases</a></li>" & @CRLF & _
" <li class="subtab "><a class=" "" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/deps/AWSBrewPricingPlcConsole?direction=down&majorVersion=1.3&graphType=runtime_dependencies-resolved">Dependencies</a></li>" & @CRLF & _
" <li class="subtab "><a class=" "" & @CRLF & _
" href="https://devcentral.amazon.com/ac/brazil/directory/package/deps/AWSBrewPricingPlcConsole?direction=up&majorVersion=1.3">Consumers</a></li>" & @CRLF & _
"</ul>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class='underNav'>" & @CRLF & _
" <div class="subNavHolder">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div id="actions">" & @CRLF & _
" <h3>Package Actions</h3>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"<form method="get"" & @CRLF & _
" action="/brazil/packages/versionDiff/">" & @CRLF & _
" <div>" & @CRLF & _
" <input type="hidden" name="packageName" value="AWSBrewPricingPlcConsole">" & @CRLF & _
" <button type="submit">" & @CRLF & _
" Diff <b>Versions</b>" & @CRLF & _
" </button>" & @CRLF & _
" </div>" & @CRLF & _
"</form>" & @CRLF & _
"" & @CRLF & _
"</div>" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<h2>Releases</h2>" & @CRLF & _
"" & @CRLF & _
"<div class="releaseNotes">" & @CRLF & _
"<table class="releaseNotes">" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="version">" & @CRLF & _
" <a name="1.3.3.0"></a><a href="https://code.amazon.com/packages/AWSBrewPricingPlcConsole/releases/1.3.3.0"><b>1.3</b>.3.0</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td class="nowrap">Tue Jan 8 01:39:08 2019</td>" & @CRLF & _
" <td>" & @CRLF & _
" AWSBrewPricingPlcConsole/<a href="/brazil/go/src-control?branch=mainline&pkg=AWSBrewPricingPlcConsole">mainline</a>@<a href="/brazil/go/src-control?branch=mainline&cln=6a10a7b2e3108941009efcfaef877b0df6a4063a&pkg=AWSBrewPricingPlcConsole">6a10a7b2e3108941009efcfaef877b0df6a4063a</a> (GitFarm)" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" <a href="https://devcentral.amazon.com/ac/brazil/directory/version-set/overview/AWSBrewPricingPlcTools/AWSBrewPricingPlcConsole">AWSBrewPricingPlcTools/AWSBrewPricingPlcConsole</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td style="width: 50%">" & @CRLF & _
" Built in <a href="https://build.amazon.com/2058367784">request 2058367784</a>" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td colspan="5" class="text">" & @CRLF & _
" <div style="overflow: auto">" & @CRLF & _
" Requester: vladyang<br>" & @CRLF & _
" [Change 6a10a7b2e3108941009efcfaef877b0df6a4063a by vladyang] adding version info<br>" & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="version">" & @CRLF & _
" <a name="1.3.2.0"></a><a href="https://code.amazon.com/packages/AWSBrewPricingPlcConsole/releases/1.3.2.0"><b>1.3</b>.2.0</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td class="nowrap">Tue Jan 8 01:20:29 2019</td>" & @CRLF & _
" <td>" & @CRLF & _
" AWSBrewPricingPlcConsole/<a href="/brazil/go/src-control?branch=mainline&pkg=AWSBrewPricingPlcConsole">mainline</a>@<a href="/brazil/go/src-control?branch=mainline&cln=3d728050bff78d98870ca70662e62bebbfa91f48&pkg=AWSBrewPricingPlcConsole">3d728050bff78d98870ca70662e62bebbfa91f48</a> (GitFarm)" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" <a href="https://devcentral.amazon.com/ac/brazil/directory/version-set/overview/AWSBrewPricingPlcTools/AWSBrewPricingPlcConsole">AWSBrewPricingPlcTools/AWSBrewPricingPlcConsole</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td style="width: 50%">" & @CRLF & _
" Built in <a href="https://build.amazon.com/2058362893">request 2058362893</a>" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td colspan="5" class="text">" & @CRLF & _
" <div style="overflow: auto">" & @CRLF & _
" Requester: vladyang<br>" & @CRLF & _
" [3d72805 by vladyang] Initial Test Set" & @CRLF & _
" </div>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="version">" & @CRLF & _
" <a name="1.3.1.0"></a><a href="https://code.amazon.com/packages/AWSBrewPricingPlcConsole/releases/1.3.1.0"><b>1.3</b>.1.0</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td class="nowrap">Tue Jan 8 00:50:19 2019</td>" & @CRLF & _
" <td>" & @CRLF & _
" AWSBrewPricingPlcConsole/<a href="/brazil/go/src-control?branch=refactorings&pkg=AWSBrewPricingPlcConsole">refactorings</a>@<a href="/brazil/go/src-control?branch=refactorings&cln=afcb73f4968c4fc6baf6beb85f8414ad1a2ab603&pkg=AWSBrewPricingPlcConsole">afcb73f4968c4fc6baf6beb85f8414ad1a2ab603</a> (GitFarm)" & @CRLF & _
" </td>" & @CRLF & _
" <td>" & @CRLF & _
" <a href="https://devcentral.amazon.com/ac/brazil/directory/version-set/overview/AWSBrewPricingPlcTools/AWSBrewPricingPlcConsole">AWSBrewPricingPlcTools/AWSBrewPricingPlcConsole</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td style="width: 50%">" & @CRLF & _
" Built in <a href="https://build.amazon.com/2058354122">request 2058354122</a>" & @CRLF & _
" </td>" & @CRLF & _
"" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td colspan="5" class="text">" & @CRLF & _
" <div style="overflow: auto">" & @CRLF & _
" Requester: vladyang<br>" & @CRLF & _
" [afcb73f by vladyang] Fixing package versioning" & @CRLF & _
" </div>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<a name="end"></a>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript"" & @CRLF & _
" src="https://internal-cdn.amazon.com/devcentral.amazon.com/brazil/directory/js/package.min.js?size=1292"></script>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div style="clear:both"></div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
" <div id='footer'>" & @CRLF & _
" <div class='column'>" & @CRLF & _
" <h3>Packages</h3>" & @CRLF & _
" <ul>" & @CRLF & _
" <li><a href="https://octane.amazon.com/package">Create Package</a></li>" & @CRLF & _
" <li><a href="/brazil/packages">Third Party Packages</a></li>" & @CRLF & _
" <li><a href="https://code.amazon.com/packages/find_by_team_for_user">Packages By Owner</a></li>" & @CRLF & _
" <li><a href="/ac/brazil/directory/packages/prune-list">Pruned Packages</a></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </div>" & @CRLF & _
" <div class='column'>" & @CRLF & _
" <h3>Version Sets</h3>" & @CRLF & _
" <ul>" & @CRLF & _
" <li><a href="https://code.amazon.com/version-sets/new">Create</a></li>" & @CRLF & _
" <li><a href="https://code.amazon.com/version-sets/">Browse</a></li>" & @CRLF & _
" </ul>" & @CRLF & _
" </div>" & @CRLF & _
" <div class='business_card'>" & @CRLF & _
" <h3>Need help?</h3>" & @CRLF & _
" <ul>" & @CRLF & _
" <li><a href="https://w.amazon.com/index.php/BuilderTools/Product/Brazil_Package_Directory">Package Directory Documentation</a></li>" & @CRLF & _
" <li><a href="https://i.amazon.com/issues/create?assignedFolder=27de5d2d-8357-4fe4-9344-7f9d95d94d6b&descriptionContentType=text%2Famz-markdown-sim&extensions%5Btt%5D%5Bimpact%5D=4">Submit an Issue (problems or suggestions)</a></li>" & @CRLF & _
" <li><a href="https://w.amazon.com/index.php/BuilderTools/OfficeHours">Office Hours</a></li>" & @CRLF & _
" </ul>" & @CRLF & _
" <div class="browser_support">" & @CRLF & _
" <a href="https://w.amazon.com/?BuilderTools/Browser_Support_Policy">Browser Support Policy</a>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"<script type="text/javascript" src="https://internal-cdn.amazon.com/devcentral.amazon.com/js/display.min.js?size=582"></script>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <script type="text/javascript" src="https://internal-cdn.amazon.com/is-it-down.amazon.com/javascripts/stripe.min.js"></script>" & @CRLF & _
" <script type="text/javascript">" & @CRLF & _
" // "Is It Down?" Stripe for Package Builder" & @CRLF & _
" isItDownStripe("brazil", 2, 1);" & @CRLF & _
" </script>" & @CRLF & _
"" & @CRLF & _
" </body>" & @CRLF & _
"</html>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")