package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:\d[ -]*?){13,16}\b`)
var str = `456688953929432`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}