package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{{\s*[\w\.\[\]]+\s*}}`)
var str = `{{Hello[0]}}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}