$re = '/(?<=\d)(?=[a-zA-Z])|(?<=[a-zA-Z])(?=\d)/';
$str = 'foo11bar22baz33hey';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);