#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]+[ ]*lbs?[ ]*[0-9]+[ ]*ozs?"
Local $sString = "6lb14ozs" & @CRLF & _
"6 lb 14ozs" & @CRLF & _
"8lb" & @CRLF & _
"8lbs" & @CRLF & _
"16lbs" & @CRLF & _
"6 lb 14ozs" & @CRLF & _
"6 lb 14 ozs" & @CRLF & _
"6 lbs 14ozs" & @CRLF & _
"6 lb 14ozs" & @CRLF & _
"69 lb 14ozs" & @CRLF & _
"6lb 14 ozs" & @CRLF & _
"6lb14 ozs" & @CRLF & _
"6 lb14 ozs" & @CRLF & _
"66lb14ozs" & @CRLF & _
"66 lb14ozs" & @CRLF & _
"65 lb 14ozs" & @CRLF & _
"66lb1ozs" & @CRLF & _
"66 lb1ozs" & @CRLF & _
"65 lb 1ozs" & @CRLF & _
"6lb14oz" & @CRLF & _
"6 lb14oz" & @CRLF & _
"6 lb 14oz" & @CRLF & _
"6 lb 14 oz" & @CRLF & _
"6lb 14 oz" & @CRLF & _
"6lb14 oz" & @CRLF & _
"6 lb14 oz" & @CRLF & _
"100lb 13ozs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")