package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[]\r\n]+\d{4}\/\d{2}\/\d{2}\s\d{2}\:\d{2}\:\d{2}\.\d{7}\s\d{4}`)
var str = `2015/08/13 18:20:35.0450892 1104 10780 Shared * START * Service startup
2015/08/13 18:20:35.0536222 1104 10780 Agent WU client version 10.0.10240.16397
2015/08/13 18:20:35.0538960 1104 10780 Agent SleepStudyTracker: Machine is non-AOAC. Sleep study tracker disabled.
2015/08/13 18:20:35.0539537 1104 10780 Agent Base directory: C:\WINDOWS\SoftwareDistribution
2015/08/13 18:20:35.0540354 1104 10780 Shared UpdateNetworkState Ipv6, cNetworkInterfaces = 8.
2015/08/13 18:20:35.0540549 1104 10780 Shared UpdateNetworkState Ipv4, cNetworkInterfaces = 2.
2015/08/13 18:20:35.0544494 1104 10780 Shared Network state: Connected
2015/08/13 18:20:35.0580648 1104 10780 Shared UpdateNetworkState Ipv6, cNetworkInterfaces = 8.
2015/08/13 18:20:35.0580736 1104 10780 Shared UpdateNetworkState Ipv4, cNetworkInterfaces = 2.
2015/08/13 18:20:35.0580804 1104 10780 Shared Power status changed
2015/08/13 18:20:35.0718558 1104 10780 Agent Initializing global settings cache
2015/08/13 18:20:35.0718573 1104 10780 Agent WSUS server: NULL
2015/08/13 18:20:35.0718583 1104 10780 Agent WSUS status server: NULL
2015/08/13 18:20:35.0718593 1104 10780 Agent Target group: (Unassigned Computers)
2015/08/13 18:20:35.0718602 1104 10780 Agent Windows Update access disabled: No
2015/08/13 18:20:35.0723643 1104 10780 Agent Timer: 855E8A7C-ECB4-4CA3-B045-1DFA50104289, Expires 2015-08-13 22:22:28, not idle-only, <NULL>network-only
2015/08/13 18:20:35.0723702 1104 10780 Agent Timer: 29A863E7-8609-4D1E-B7CD-5668F857F1DB, Expires 2015-08-14 17:45:53, not idle-only, not network-only
2015/08/13 18:20:35.0767535 1104 10780 Agent Initializing Windows Update Agent
2015/08/13 18:20:35.0768073 1104 10780 DownloadManager Download manager restoring 0 downloads
2015/08/13 18:20:35.0768674 1104 10780 Agent CPersistentTimeoutScheduler | GetTimer, returned hr = 0x00000000
2015/08/13 18:20:35.2159607 1104 11340 DownloadManager PurgeExpiredFiles::Found 0 expired files to delete.
2015/08/13 18:20:35.2217267 1104 11340 DownloadManager PurgeExpiredUpdates::Found 606 non expired updates.
2015/08/13 18:20:35.3462873 1104 11340 DownloadManager PurgeExpiredUpdates::Found 0 expired updates.
2015/08/13 18:20:35.3466012 1104 11340 Shared Effective power state: AC`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}