import re
regex = re.compile(r"^(?<User>[_a-z0-9-]+(\.[_a-z0-9-]+)*(?<GmailTag>\+[\._a-z0-9-]+){0,1})@(?<Host>[a-z0-9-]+(\.[a-z0-9-]+)*\.[a-z]{2,4})$", flags=re.IGNORECASE)
test_str = "kevimetal.matyrock+asdasd@google.mail.com"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")