package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^:]+:){2}([^:]*)`)
var str = `boo+foo:qoo+loo:thisIsWhatIneed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}