#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*([A-Z]*)\s+(.*)$"
Local $sString = "FCB: EQU 5CH" & @CRLF & _
"SYSTEM: EQU 5" & @CRLF & _
"OPEN: EQU 15" & @CRLF & _
"CLOSE: EQU 16" & @CRLF & _
"SETDMA: EQU 26" & @CRLF & _
"CREATE: EQU 22" & @CRLF & _
"DELETE: EQU 19" & @CRLF & _
"READ: EQU 20" & @CRLF & _
"WRITE: EQU 21" & @CRLF & _
"PRNBUF: EQU 9" & @CRLF & _
" MOV SP,STACK" & @CRLF & _
" MOV DX,HEADER" & @CRLF & _
" MOV CL,9 " & @CRLF & _
" CALL SYSTEM" & @CRLF & _
" MOV BX,FCB+12" & @CRLF & _
" XOR AL,AL" & @CRLF & _
" MOV CH,4 " & @CRLF & _
"CLRFCB:" & @CRLF & _
" MOV [BX],AL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")