$re = '~^/[^\r\n]+/(?>([imus])(?!.*?\1))*+$~s';
$str = '/\\s+/imus';
$subst = "_";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;