using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((2[0-4]\d|25[0-5]|1?\d?\d)\.){3}(2[0-4]\d|25[0-5]|1?\d?\d)";
string input = @"
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}