$re = '/TMP_\w+/mi';
$str = 'tmp_123
tmp_123_abc
tmp_123-abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);