re = /(?<!\\)'/
str = 'I want to replace \' with \\\' but not \\\' since they are already escaped
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end