$re = '/^(?=.*Word1)(?=.*Word2).*/ms';
$str = '1. apple Word1
banana Word2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);