$re = '/^(19[789]\d|2\d{3})-((0[13578]|1[02])-([0-2]\d|3[01])|02-[0-2]\d|0[469]|11-([0-2]\d|30))T([01]\d|2[0-4])(:[0-5]\d){2}Z$/';
$str = '2016-11-09T01:00:23Z';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);