package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(
(
G(?<Gdata>\d+)
|
X(?<Xdata>\d+)
|
Y(?<Ydata>\d+)
|
Z(?<Zdata>\d+)
|
F(?<Fdata>\d+)
)
\s*
)+`)
var str = `G01`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}