import re
regex = re.compile(r"[[^\[{1}(?![[:digit:]]\){1}", flags=re.MULTILINE)
test_str = ("-0.2122,-0.1213\n"
"-0.2750,-0.2122\n"
"-0.1213,-0.0222\n"
"-0.1213,-0.0222")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")