$re = '/\bfrom company\b.*?\K\b(?<!\$|[\d.])(?:\d++)\b/';
$str = 'This is invoice from company XYZ - $1234545 product name 31h10 , $456.12 product number g456, 123f 456 information invoice unit cost $12.0 and invoice total $1343.00
This is invoice from company ABC - 1234545 product name and information invoice total cost $6777 and invoice unit cost $654';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);