re = /embed\/([^?\s]*)/m
str = 'https://www.youtube.com/embed/f2fJsDFJ23?autoplay=1
https://www.youtube.com/embed/f2fJsDFJ23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end